WiFi connect and Philips hue

#1

hi there…
im trying to create a simple trigg. When either my phone or misses phone connects to wifi it turns on some of my hue lights that ive selected.
its all set up to what i believe is correct but NOTHING at all happens…

Any help would be great ty


ive selected my wifi
ive selected CONNECT on the wifi and then select the phone i want

update.
ive also tried it when the lights are on and the wifi disconnects it turns them off…still nothing happens

#2

Make sure your trigg is enabled, do a test run, then check the activity log at the bottom of the trigg overview. Does it show the trigg ran at the intended time? And is there any error code for the action?

If the trigg didn’t run, then you need to focus on why the trigger condition isn’t happening. If the trigg did run, then you need to focus on why the Hue bulb action isn’t happening. An error code might give a clue. You could also construct a test where a Now button triggers the same action with the Hue bulbs.

#3

ive done a test run by turning wfi off on my phone then turning it back on and nothing.
as u can see from the image its not activated at all

ill try with a button on it to see if that does anything

#4

if i do it with just a test button. the lights turn on fine.

#5

Works for me doing the same thing as you have described. I set my trigg conditions as WiFi Connected and Last connected network = my home WiFi network. Turn off WiFi on my phone. Turn it back on again and reconnect to home network -> trigg fires.

#6

ive tried number of times it just doesnt want to know. Ive tried it using IFTTT and it works like a dream. only thing is u cant do times or select diffrent phones…where this app comes in super useful. Every other trigg works like a dream…just this one isnt having it

#7

ive just tried it with a push notification and send a email to eliminate the hue lights, and that didnt wrk either…so i def think its the wifi section now

#9

If it’s not triggering for you with the same test procedure, then there must be something different.

I’m testing on an LG phone running Android 7.1. When I first selected a WiFi condition for a trigg in Olisto, it prompted me to select a device, and the only option was the LG phone, which I duly selected. I was then able to add the WiFi connected and Last Wifi network conditions.

To test, I start with the phone connected to my home WiFi network. I turn off WiFi, wait a few seconds, then turn it back on. Phone reconnects to my home WiFi network. Trigg fires.

I tried connecting to a different WiFi network (my Guest network), and that didn’t trigger anything.

#10

odd enough i tried with a LG5 phone and as soon as i pressed use Trigg. The lights turned on
i turned the lights off and disconnected the WiFi and reconnected it and nothing happens

my Original phones ive tried with are Samsung S9 and Samsung A70

#11

I talked with the developer who is currently primarily responsible for this functionality. We think it might have something to do with the version of Android you are running, which would mean it’s a more widespread problem. Strange though, since we have tested it before on Android 9. However, we now have a galaxy S9 and S10 to test it on so we will be looking at it asap and keep you all posted!

#12

Great stuff thank you for looking into this and hopefully this can be sorted out soon… Thanks again

#13

have you tried to reverse the two primary triggers?.
First ‘wifi is connected’ and second ‘last connected network is’ ?

that sound more logical…

#14

@JoostD The order of conditions doesn’t matter. Not for this, nor for any trigg :wink:

#15

To be fair I did actually try that and didn’t work either
I’ve been trying to connect it to IFTTT but I can’t get the hang of that
I was thinking if I used IFTTT to connect to the WiFi and then it would send the trigger to olisto that would work… But I’m getting myself confused with the information I need to put into IFTTT

#16

We have identified the problem and it is indeed related to the latest Android Pie update. We are currently working on a fix, but this may take a few days. Progress will be posted here.

#17

Great stuff Remy and thanks alot… Look forward to it… :slight_smile:

#18

We’ve finished the fix and are currently testing it. It should be in the next release (2.24.2)

#19

Superb stuff look forward to tring it out :smiley:

#20

Any news on the Beta update yet?