Fitbit triggers not working

Hi, I’ve just installed Olisto. I want it to activate Lifx scenes depending on Fitbit triggers. I’ve tested Lifx on its own with time triggers, and that works. But the Fitbit triggers are ignored. If I set it to activate a Lifx scene if I go above a certain number of steps or sleep hours, for instance, nothing happens, and the trigg does not run.

Here is a screenshot of one trigg as an example. This has two triggers, but it doesn’t work when it’s Fitbit alone either.

Now I’m getting this, which at least shows that something is wrong? But I don’t know what to do about it. I restarted Olisto and the error messages are gone.

Have you checked if the data that you are using as in the ‘When’ (step count, distance) are up-to-date in your Fitbit app? Fitbit only synchronizes these numbers from the tracker every once in a while to preserve battery life and we only get the new numbers after such a synchronization is done. So unfortunately conditions from Fitbit trackers will never work in real time.

The errors you see in the last screenshot are caused by a know bug in our app that we’re still trying to solve. They should not have any impact on the correct execution of the triggs.

Yep, I keep syncing it, trying again, trying a new step count, trying again. Nothing happens at all.

Oh, and waiting, I’ve tried that too! I originally had triggs set up for when my sleep is logged, and nothing happened with those either.

Thanks, I’ve asked my colleague who is more knowledgeable about the Fitbit channel to look into this!

Thank you. Any luck?

Hi Eve,

Our apologies for the delay. The colleague in question had been ill and your case was not transferred correctly. We have looked into your case have seen a possible reason for the bug. The problem seems to be isolated to your account. I would like to ask you to try and resync your Fitbit. Then we can monitor if the connection between Fitbit and Olisto is working correctly now or whether there is more to the problem.

Kind regards,
Remy

Dear Remy,

Thanks, and best wishes to your ill team member.

What do you mean by resyncing? If you mean the ordinary syncing that Fitbit does multiple times a day, that will have happened thousands of times by now. If you mean deleting the Fitbit channel from my Olisto app and adding it back again, I tried that when I made the original post.

Dear Eve,

Could you check two things for me:

  • When you go to Fitbit and log in, does it show Olisto as an allowed application like in the image below?

  • When you check your Fitbit profile on the website. (After logging in, click your name in the top left corner as shown in the image below)

Does the graph for steps show any data, or is it empty like in this image?

Olisto isn’t listed as an allowed app, but yes, steps show up.

Ah, this will explain why we are not getting any updates from your fitbit account then. I have updated something in your account. If you could follow the following steps, it should hopefully resolve the problem:

  • Completely exit the app (and remove it from background processes)
  • Reopen the Olisto app.
  • Go to More → Channels → Fitbit (the tile should show a red exclamation mark)
    image
  • Click the reconnect button
  • Finally, click Allow all (all fields should be selected) and press the allow button.
  • After this, please check if Olisto is now listed as an allowed application.
  • If it is listed, please check the working of your triggs.
  • If there is any problem with any of the steps, please let me know.
1 Like

OK, I’ve done all that, but there still no sign of it in the Fitbit settings page.

How incredibly strange… I will discuss what other solutions are available and get back to you tomorrow!

1 Like

Thank you! Everything else I’ve ever authorised is there, if it helps. Most of them were apps I don’t use any more, so I had a good clean out.

I have sent you a PM

Remy was great and the problem is now solved. It turned out that when I logged into Fitbit in Olisto, I clicked the “log me in with Gmail” option, and that used the googlemail .com form of my email address. But the Fitbit settings page was using the gmail. com form of my address. I’ve had trouble with this before, with Lifx in particular. I clicked “not you” when reconnecting, then manually entered my address as gmail .com, and it is now properly connected and my triggs work. (Edited because it complained that I had too many links in my post.)

2 Likes