Annoying bug in Olisto app

App version: 2.26.0
Phone OS: Android 7.1

I had a Trigg with a webhook call as the action, with a complex long url containing a key and a JSON data POST section. It was working fine, but I needed to test a different approach due to an unrelated problem. I renamed and disabled my Trigg, then created a new Trigg with the old name to try my new approach. After testing I decided the old way was better, so I went back to re-enable the old Trigg.

Unfortunately the old Trigg is now labeled Error, and when I try to access it, I am not allowed to view the Action with the complex url and POST data that I was trying to preserve. The frustrating thing is that I can see the first little bit of it on the screen, but when I click on the Action it says “Error: broken action” and won’t let me look at it. I can’t even turn the screen sideways to see a little more of the cut-off url because the Olisto app doesn’t support sideways screen orientation. It goes on to say “Don’t worry, this action will be deleted when you save the Trigg”. Thanks for telling me not to worry, but I AM worried because I don’t want to delete the action, I want to see it, but I’m afraid it’s lost to me now even though the app still has the data and won’t let me see it.

Of course I would have preserved this data in a backup long ago if it were possible to do so, but backup of Triggs is a feature apparently still lacking with Olisto.

So there are 2 bugs here:

  1. Why did a working action change to Error when nothing in it was changed?

  2. Why won’t the Olisto app let me at least look at the action so I can copy the data or attempt to fix it?

Hi @DPAmes, For answering your first question, can you tell us (per PM if you prefer) the name of the trigg this is about? Hopefully we can also fix the situation for you then, of course it should not have gotten into this error state for no clear reason.
As to your second question. You’ve pretty much answered the ‘why’ yourself; there is no landscape view, and the portrait view is not suitable for displaying the full content in this case. I agree it is very unfortunate that you can’t check the entire contents of your trigg this way. Unfortunately I don’t think there will be an opportunity to improve on this in the short term, but when there is we’ll keep cases such as yours in mind.

One way to ‘back up’ your trigg might be to use the Share Trigg function.


I preserved the original Trigg that had the error in case you can look into it, or find some way to rescue it. I could reconstruct it with some work, but instead I just duplicated the function a different and easier way.

It was called “Let there be light old”. Unfortunately I also tried your suggestion about using Share Trigg to copy and paste it, and since there was no way to rename the Trigg in that process, it wiped out the existing Trigg, which is now blank (and still shows Error). So there’s another bug: if a shared Trigg link is copied back to an account where a Trigg of the same name already exists, it should either warn and offer Cancel, do nothing, or best: create a new Trigg with Copy appended to the name. It should not wipe out the existing Trigg without warning.

As for the other issue, the bug is not lack of support for landscape mode, it is that the Olisto app won’t let me open the Action that has the error so that I can look at it, edit it, or copy it. The Action with the Error was still there, and I could see that the data was still there within the Action (it is just cut off on the overview). There is no reason for the app not to let me open that Action for editing. That’s the bug.

Hey @DPAmes, our logs indicate that the action data had already disappeared before you tried the copy/paste trick with the share function. It seems this happened when the trigg was saved on the evening before you tried the share function trick.
The error you were seeing (and not being able to edit an action or condition) happens when for whatever reason the data found in one of a triggs actions or conditions does not match the data that should be there for that action or condition, and therefore the app can’t figure out how to present it anymore. This is also why (indeed, quite unfortunate and perhaps unnecessary) you would not be able to ‘open’ the action to inspect it.

It seems the trigg got broken initially because of a mistake on our part. When we recently introduced the possibility to set headers on HTTP requests we ran a migration to add an empty headers list to all existing triggs with such actions, exactly to prevent this problem. However for reasons I don’t understand it seems your trigg was skipped by this migration script. Because of that your action did not have the (empty) headers field, and because of that the app was missing data to make the action presentable. We’re very sorry for the inconvenience this caused you. I’ll still try to figure out why your trigg wasn’t migrated, and when we get the opportunity I’ll see if we can make the trigg editor a bit more forgiving in handling triggs with ‘incomplete’ data.

Thanks Daniel. That explains what happened.

It’s ok. I could have re-created the lost Action - it would just have taken a bit of time to find the lost key and JSON data, and copy it again to the Android app. I did it a different way that was simpler, so all good.

It really would be helpful to have a way to back up the Triggs, even just a text copy of the contents. There doesn’t seem to be any way to do that, or to create a copy of a Trigg with a new name, which would also be helpful when about to experiment. :slightly_smiling_face: